TryFREEProduct Before You Buy!
For Cinema 4D User
General Usage #
Step 1: Download the following 3 files(Replace <nubmer> and <render> to your collection number and render):
- MT_PM_V<number>_Cinema4D_<render>.7z
- MT_PM_V<number>_Maps.7z
- MT_PM_V<number>_Thumbnails.7z
Step 2: Unzip these 3 files, and copy all files in folder “MT_PM_V<number>_Thumbnails” to folder “MT_PM_V<number>_Cinema4D_<render>“. The result will look like the image below.

Step 3: The texture path is set to a relative path, so the texture will miss by default, you can relink textures from the “Edit” menu, “Edit > Preferences > Files > Asset Paths“, add “MT_PM_V<number>_Maps” folder to the Path. Or from the “Window” menu, “Window > Project Asset Inspector“.
Note: Redshift users should relink from “Windows > Redshift Asset Manager”